]> git.baikalelectronics.ru Git - openembedded-baikal.git/commitdiff
Add recipes for benchmarks
authorBaikal Electronics <support@baikalelectronics.ru>
Thu, 1 Dec 2022 13:47:13 +0000 (16:47 +0300)
committerBaikal Electronics <support@baikalelectronics.ru>
Thu, 1 Dec 2022 13:47:13 +0000 (16:47 +0300)
meta-baikal/recipes-core/images/core-image-minimal.bbappend
meta-baikal/recipes-support/benchmarks/benchmarks_1.0.bb [new file with mode: 0644]
meta-baikal/recipes-support/libgpiod/libgpiod.bb [new file with mode: 0644]

index 55efb8cd10ded7486def82d5e259a45ccd9ae5ea..093cdf73d52d4457ef1f603a80f992d0fbc1bd66 100644 (file)
@@ -2,11 +2,14 @@ IMAGE_ROOTFS_SIZE = "16384"
 IMAGE_NAME = "${PN}-baikal"
 
 RDEPENDS:append = " kernel-modules"
-IMAGE_INSTALL:append = " kernel-modules"
+#IMAGE_INSTALL:append = " kernel-modules"
 IMAGE_INSTALL:append = " dropbear"
-IMAGE_INSTALL:append = " e2fsprogs"
-IMAGE_INSTALL:append = " strace"
-IMAGE_INSTALL:append = " kexec-tools"
+#IMAGE_INSTALL:append = " e2fsprogs"
+#MAGE_INSTALL:append = " strace"
+#IMAGE_INSTALL:append = " kexec-tools"
+# IMAGE_INSTALL:append = " i2c-tools"
+# IMAGE_INSTALL:append = " lmsensors"
+IMAGE_INSTALL:append = " benchmarks"
 EXTRA_IMAGE_FEATURES += "debug-tweaks"
 
 baikal_deploy () {
diff --git a/meta-baikal/recipes-support/benchmarks/benchmarks_1.0.bb b/meta-baikal/recipes-support/benchmarks/benchmarks_1.0.bb
new file mode 100644 (file)
index 0000000..f6dc666
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY = "SDK benchmarks"
+LICENSE = "MIT"
+
+DESCRIPTION = "Bencmarks from SDK"
+PN = "benchmarks"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "git://git@swgit/benchmarks.git;protocol=ssh;branch=testing_bb_benchmarks"
+SRCREV = "200371693b9c0328200270e6f52eefaff4f210bc"
+
+
+INSANE_SKIP:${PN} += "already-stripped"
+INSANE_SKIP:${PN}-native += "already-stripped"
+
+# File /gpio_test in package benchmarks doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
+INSANE_SKIP:${PN} += " ldflags"
+
+S = "${WORKDIR}/git"
+DEPENDS:append = " libgpiod autoconf-archive"
+
+
+do_install () {
+               install -d ${D}${bindir}
+        oe_runmake "DESTDIR=${D}/${bindir}" install
+}
+
+
+FILES:${PN} = "${bindir}"
diff --git a/meta-baikal/recipes-support/libgpiod/libgpiod.bb b/meta-baikal/recipes-support/libgpiod/libgpiod.bb
new file mode 100644 (file)
index 0000000..c83d4bc
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+
+PN = "libgpiod"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+
+SRC_URI = "git://github.com/brgl/libgpiod.git;protocol=https;branch=master"
+SRCREV = "cc23ef61f66d5a9055b0e9fbdcfe6744c8a637ae"
+
+S = "${WORKDIR}/git/"
+inherit autotools pkgconfig
+
+#PACKAGECONFIG ?= "tools"
+PACKAGECONFIG ?= ""
+DEPENDS = "autoconf-archive"
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+PACKAGECONFIG[toolsss] = "--enable-tools,--disable-tools,"
+